From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.



将LabVIEW老的模块安装在新版本的LabVIEW上面



主要软件:
主要软件版本: 8.0
主要软件修正版本: N/A
次要软件: N/A

问题: 我想LabVIEW应该是向下兼容的。例如,为何我不能在LabVIEW 8.0上面安装LabVIEW DSC,FPGA,PDA或Real-Time 7.1的模块?

解答:

VI 和LabVIEW 的工具包与新版本的LabVIEW是向下兼容的。例如,你可以在LabVIEW 8.0下面使用老的PID 控制工具包,然而,LabVIEW 模块,是LabVIEW本身整体的一部分,必须和LabVIEW同样的版本。所以,你必须在在LabVIEW 8.0 下面安装LabVIEW Real-Time 8.0. 在下面的链接中是LabVIEW 模块和工具包以及它们兼容性的列表。

被先前版本LabVIEW RT, PDA, 和FPGA 模块建立的VI是被新版本向下兼容的。有一个将LabVIEW DSC 7.1和更早工程为导入LabVIEW DSC 8.x的工具。

同时,请注意LabVIEW RT模块,目标RT 控制器与上位机的LabVIEW RT模块必须版本完全一致。如果LabVIEW 和RT 模块的两种版本都在上位机中装了,可以根据需要使用哪个版本的VI 或RT 来在MAX中选择希望安装到目标控制器的RT 版本。



相关链接: LabVIEW Module and Toolkit Compatibility Information

附件:





报告日期: 01/03/2006
最近更新: 05/27/2009
文档编号: 3T2CKG7U