From 08:00 PM CDT Friday, August 12 - 01:00 PM CDT Saturday, August 13, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.



NI的驱动和软件支持哪些Linux发行版?



主要软件:
主要软件版本: 1.1
主要软件修正版本: N/A
次要软件: N/A

问题: NI的驱动和软件支持哪些Linux发行版?

解答:

关于发行版的支持请参考下表。预览图可以放大。


注意:关于更老版本的Linux发行版和NI的软件,请参考本文末的LinuxSupportMaxtrix.xls 

对于未认证的软件/驱动包,只更新NI-KAL不能支持openSUSE 11.2。你需要安装经认证的软件/驱动,例如NI-VISA 5.0。

打√+ 表示软件/驱动包通过了在该Linux发行版的认证 。不需要更行NI-KAL。关于支持的硬件,请参考产品的README文件。

打√ 表示软件/驱动包通过了在该Linux发行版的认证。但是在安装软件前,需要把NI-KAL更新到合适的版本。关于支持的硬件,请参考产品的README文件。
 
打√- 表示软件/驱动包没有通过该Linux发行版的认证,但是通过安装合适版本的NI-KAL或者是其他办法,有可能在该发行版上运行。建议在部署系统前做更多的用户测试。

打O 表示该配置不受NI支持。建议在使用该配置部署系统前做更多的用户测试。

打x表示经过测试后,我们已经确定有些较大的问题,包括编译警告、甚至系统崩溃。不推荐使用这种组合,且不能得到NI技术支持。
 
我的Linux发行版没有列在上面的表格中,NI的支持政策是怎样的?
如果你的发行版没有出现在上面的表格中,你可以认为所有的行都打‘O’。

当你安装NI-KAL时,它是一个编译好的底层驱动。NI-KAL为NI驱动和你的Linux内核提供无缝接合。每个NI linux驱动都包含了某个版本的NI-KAL。

什么是"合适版本的NI-KAL"?
为了使用Linux内核的频繁更新,NI-KAL也需要经常改动以保持兼容性。有时,如果你的驱动本来在某个linux发行版不能运行,通过更新NI-KAL可以解决这个问题。NI-KAL支持一下发行版:
 
NI-KAL 2.0:
  • Red Hat Enterprise Linux Desktop + Workstation 5
  • Red Hat Enterprise Linux Workstation 4
  • openSUSE 11.2
    • Note: NI-KAL 2.0 by itself does not contain support for openSUSE 11.2. In order to obtain support for this distribution, please download and install the NI-VISA Run-Time Engine 5.0 (Beta)
  • openSUSE 11.1
NI-KAL 1.10:
  • Red Hat Enterprise Linux Desktop + Workstation 5
  • Red Hat Enterprise Linux Workstation 4
  • openSUSE 11.1 (Beta support)
  • openSUSE 11.0
  • openSUSE 10.3
NI-KAL 1.9:
  • Mandriva Linux 2008, 2009
  • openSUSE 10.3, 11.0 
  • Red Hat Enterprise Linux WS 4
  • Red Hat Enterprise Linux Desktop + Workstation 5
NI-KAL 1.8:
  • Mandriva Linux 2007, 2008
  • openSUSE 10.2, 10.3
  • Red Hat Enterprise Linux WS 4
  • Red Hat Enterprise Linux Desktop + Workstation 5
NI-KAL 1.7:
  • Mandriva Linux 2007, 2008
  • openSUSE 10.2, 10.3
  • Red Hat Enterprise Linux WS 4
  • Red Hat Enterprise Linux Desktop + Workstation 5
NI-KAL 1.6:
  • Mandriva Linux 2006, 2007
  • SUSE Linux 10.1
  • openSUSE 10.2
  • Red Hat Enterprise Linux WS 4
  • Red Hat Enterprise Linux Desktop + Workstation 5
NI-KAL 1.5:
  • Mandriva Linux 2006, 2007
  • SUSE Linux 10.1
  • openSUSE 10.2
  • Red Hat Enterprise Linux WS 3, 4
NI-KAL 1.4:
  • Mandrakelinux 10.1
  • Mandriva Linux 2006
  • SUSE Linux 10.0, 10.1
  • Red Hat Enterprise Linux WS 3, 4
NI-KAL 1.3:
  • Mandrakelinux 10.1
  • Mandriva Linux 2006
  • SUSE LINUX Professional 9.3
  • SUSE Linux 10.0
  • Red Hat Enterprise Linux WS 3, 4
NI-KAL 1.2:
  • Mandrakelinux 10.1
  • Mandriva Linux 2006
  • SUSE LINUX Professional 9.2, 9.3
  • Red Hat Enterprise Linux WS 3, 4
NI-KAL 1.1:
  • Mandrakelinux 10.0, 10.1
  • SUSE LINUX Professional 9.1, 9.2
  • Red Hat Enterprise Linux WS 3
NI-KAL 1.0:
  • Mandrakelinux 10.0 
  • SUSE LINUX Professional 9.1 
  • Red Hat Enterprise Linux WS 3

我想使用在上表中未经认证的配置。既然NI不提供支持,你能给我些提示吗?
首先,要安装官方支持发行版的NI-KAL,然后载入实际的软件包。这个可能使这种软件组合的成功率最高。其次, NI Discussion Forums是个大家交流未经认证的配置和发行版的好地方。很多用户对怎样在不同的linux发行版上安装不同的产品写了很多文档,这些文档在 Linux Users Community Group. 如果没有现成的文档,我们鼓励您自己创建一个。

我到哪里下载NI-KAL?

你可以从NI Drivers and Updates (NI驱动与升级)页下载到不同版本的NI-KAL

 

 



相关链接: Linux Users Community
Measurement and Control Products for Linux
NI LabWindows/CVI Run-Time Module for Linux®
Developer Zone Tutorial: Introduction to the LabWindows/CVI Run-Time Module for Linux®
National Instruments and Linux: Frequently Asked Questions
NI Discussion Forums

附件:





报告日期: 08/24/2010
最近更新: 08/14/2011
文档编号: 5CNEG20S