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This course prepares you to do the following:

Å Use LabVIEW to create applications.

Å Understand front panels, block diagrams, and icons and connector panes.

Å Use built-in LabVIEW functions.

Å Create and save programs in LabVIEW so you can use them as subroutines.

Å Create applications that use plug-in DAQ devices.

This course does not describe any of the following:

Å Programming theory

Å Every built-in LabVIEW function or object

Å Analog-to-digital (A/D) theory

NI does provide free reference materials on the above topics on ni.com . 

The LabVIEWHelp is also very useful:

LabVIEW»Help»Search the LabVIEW Helpé



Virtual Instrumentation

For more than 30 years, National Instruments has revolutionized the way engineers and 

scientists in industry, government, and academia approach measurement and 

automation. Leveraging PCs and commercial technologies, virtual instrumentation 

increases productivity and lowers costs for test, control, and design applications 

through easy-to-integrate software, such as NI LabVIEW, and modular measurement 

and control hardware for PXI, PCI, USB, and Ethernet. 

With virtual instrumentation, engineers use graphical programming software to create 

user-defined solutions that meet their specific needs, which is a great alternative to 

proprietary, fixed-functionality traditional instruments. Additionally, virtual 

instrumentation capitalizes on the ever-increasing performance of personal computers. 

For example, in test, measurement, and control, engineers have used virtual 

instrumentation to downsize automated test equipment (ATE) while experiencing up to 

a 10 times increase in productivity gains at a fraction of the cost of traditional 

instrument solutions. Last year 25,000 companies in 90 countries invested in more than 

6 million virtual instrumentation channels from National Instruments. 



National Instruments LabVIEW is an industry-leading software tool for designing test, 

measurement, and control systems. Since its introduction in 1986, engineers and 

scientists worldwide who have relied on NI LabVIEW graphical development for 

projects throughout the product design cycle have gained improved quality, shorter time 

to market, and greater engineering and manufacturing efficiency. By using the 

integrated LabVIEW environment to interface with real-world signals, analyze data for 

meaningful information, and share results, you can boost productivity throughout your 

organization. Because LabVIEW has the flexibility of a programming language 

combined with built-in tools designed specifically for test, measurement, and control, 

you can create applications that range from simple temperature monitoring to 

sophisticated simulation and control systems. No matter what your project is, LabVIEW 

has the necessary tools to make you successful quickly. 



Virtual Instrumentation Applications

Virtual instrumentation is effective in many different types of applications, from design to 

prototyping to deployment. The LabVIEW platform provides specific tools and models to meet 

specific application challenges, ranging from designing signal processing algorithms to making 

voltage measurements, and can target any number of platforms from the desktop to embedded 

devices ïwith an intuitive, powerful graphical paradigm.

With Version 8.6, LabVIEW scales from design and development on PCs to several embedded 

targets, from rugged toaster-size prototypes to embedded systems on chips. LabVIEW

streamlines system design with a single graphical development platform. In doing so, it 

encompasses better management of distributed, networked systems because as the targets for 

LabVIEW grow varied and embedded, you need to be able to more easily distribute and 

communicate between the various LabVIEW code pieces in your system. 



Integrated Hardware Platforms

A virtual instrument consists of an industry-standard computer or workstation equipped 

with powerful application software, cost-effective hardware such as plug-in boards, and 

driver software, which together perform the functions of traditional instruments. 

Virtual instruments represent a fundamental shift from traditional hardware-centered 

instrumentation systems to software-centered systems that exploit the computing power, 

productivity, display, and connectivity capabilities of popular desktop computers and 

workstations. 

Although the PC and integrated circuit technology have experienced significant 

advances in the last two decades, software truly offers the flexibility to build on this 

powerful hardware foundation to create virtual instruments, providing better ways to 

innovate and significantly reduce cost. With virtual instruments, engineers and scientists 

build measurement and automation systems that suit their needs exactly (user-defined) 

instead of being limited by traditional fixed-function instruments (vendor-defined).





This LabVIEW course is designed for audiences with or without access to National 

Instruments hardware. 

Each exercise is divided into three tracks, A, B, and C

Track A is designed to be used with hardware supported by the NI-DAQmx driver. This 

includes most USB, PCI, and PXI data acquisition devices with analog input. Some 

signal conditioning and excitation (external power) is required to use a microphone with 

a DAQ device.

Track B is designed to be used with no hardware. You can simulate the hardware with 

NI-DAQmx Version 8.0 and later. This is done by using the NI-DAQmx Simulated 

Device option in the Create New menu of MAX. The simulated deviceôs driver is 

loaded, and programs using it are fully verified. 

Track C is designed to be used with a standard sound card and microphone. LabVIEW

includes simple VIs for analog input and analog output using the sound card built into 

many PCs. This is convenient for laptops because the sound card and microphone are 

usually already built-in.



Track A ïNI Data Acquisition with Microphone
USB-6009, Microphone and LED

Suggested Hardware

The following schematic was drawn with NI Multisim , a widely used SPICE schematic capture 

and simulation tool. Visit ni.com/ Multisim for more info.

Setting Up Your Hardware for Your Selected Track

Qty Part Number Description Supplier

1 779321-22 Low-Cost USB DAQ National Instruments

1 270-092 Electret Microphone RadioShack

1 100 ÝResistor RadioShack

1 220 ÝResistor RadioShack

1 276-307 Light Emitting Diode (LED) RadioShack

Track B ïSimulated NI Data Acquisition
NI-DAQmx Software Version 8.0 or later 

Track C ïThird -Party Sound Card
Sound card and Microphone

Suggested Hardware

* Laptops often have a built-in microphone (no plug-in microphone is required)

Qty Part Number Description Supplier

1 Standard Plug-In PC Microphone* RadioShack



What type of device should I use?

There are many types of data acquisition and control devices on the market. A few have been 

highlighted above. The trade-off usually falls between sampling rate (samples/second), 

resolution (bits), number of channels, and data transfer rate (usually limited by ñbusò type: 

USB, PCI, PXI, and so on). Multifunction DAQ (data acquisition) devices are ideal because 

they can be used in a wide range of applications.

NI USB-6008 and USB-6009 Low-Cost USB 

DAQ

The National Instruments USB-6009 device 

provides basic data acquisition functionality for 

applications such as simple data logging, portable 

measurements, and academic lab experiments. The 

USB-6008 and USB-6009 are ideal for students. 

Create your own measurement application by 

programming the 

USB-6009 using LabVIEW and NI-DAQmx

driver software for Windows. For Mac OS X and 

Linux® users, download and use the NI-DAQmx

Base driver.

USB-6009 Specifications:

ÅEight 14-bit analog inputs

Å12 digital I/O lines

Å2 analog outputs

Å1 counter

ni.com/daq
Linux® is the registered trademark of 

LinusTorvaldsin the U.S. and other 

countries. 



The next level of software is called Measurement & Automation Explorer (MAX). 

MAX is a software interface that gives you access to all of your National Instruments 

DAQ, GPIB, IMAQ, IVI, Motion, VISA, and VXI devices. The shortcut to MAX 

appears on your desktop after installation. A picture of the icon is shown above. MAX is 

mainly used to configure and test your National Instruments hardware, but it does offer 

other functionality such as checking to see if you have the latest version of NI-DAQmx

installed. When you run an application using NI-DAQmx, the software reads the MAX 

configuration to determine the devices you have configured. Therefore, you must 

configure DAQ devices first with MAX.

The functionality of MAX falls into six categories:

Å Data Neighborhood

Å Devices and Interfaces

Å IVI Instruments

Å Scales

Å Historical Data

Å Software

This course will focus on Data Neighborhood, Devices and Interfaces, Scales, Software, 

and you will learn about the functionality each one offers. 



Exercise 1 ðTesting Your Device (Track A)

In this exercise, use Measurement and Automation Explorer (MAX) to test

your USB-6009 DAQ device. 

1. Launch MAX by double-clicking the icon on the desktop or by selecting Start»

Programs»NationalInstruments»Measurement& Automation .

2. Expand the Devices and Interfacessection to view the installed National 

Instruments devices. MAX displays the National Instruments hardware and software 

in the computer. 

3. Expand the NI-DAQmx Devicessection to view the installed hardware that is 

compatible with NI-DAQmx. The device number appears in quotes following the 

device name. The data acquisition VIs use this device number to determine which 

device performs DAQ operations. Your hardware is listed as NI USB-6009: 

ñDev1.ò

4. Perform a self-test on the device by right-clicking it in the configuration tree and 

choosing Self-Testor clicking Self-Testalong the top of the window. This tests the 

system resources assigned to the device. The device should pass the test because it is 

already configured. 

5. Check the pinoutfor your device. Right-click the device in the configuration tree 

and select Device Pinoutsor click Device Pinoutsalong the top of the center 

window. 

6. Open the test panels. Right-click the device in the configuration tree and select Test 

Panelséor click Test Panelsé along the top of the center window. With test 

panels, you can test the available functionality of your device, analog input/output, 

digital input/output, and counter input/output without doing any programming. 

7. On the Analog Input tab of the test panels, change Modeto ñContinuousò and Rate

to ñ10,000 Hz.ò Click Start and hum or whistle into your microphone to observe the 

signal that is plotted. Click Stopwhen you are done. 

8. On the Digital I/O tab, notice that initially the port is configured to be all input. 

Observe under Select Statethe LEDs that represent the state of the input lines. 

Click the All Output button under Select Direction. Notice you now have switches 

under Select Stateto specify the output state of the different lines. Toggle line 0 and 

watch the LED light up. Click Closeto close the test panels.

9. Close MAX.



End of Exercise 1 (Track A)



Exercise 1 ðSetting Up Your Device (Track B)

In this exercise, use Measurement and Automation Explorer (MAX) to configure a 

simulated DAQ device. 

1. Launch MAX by double-clicking the icon on the desktop or by selecting Start»

Programs»NationalInstruments»Measurement& Automation .

2. Expand the Devices and Interfacessection to view the installed National 

Instruments devices. MAX displays the National Instruments hardware and software 

in the computer. The device number appears in quotes following the device name. 

The data acquisition VIs use this device number to determine which device performs 

DAQ operations. 

3. Create a simulated DAQ device for use later in this course. Simulated devices are 

a powerful tool for development without having hardware physically installed in 

your computer. Right-click Devices and Interfacesand select Create Newéè

NI-DAQmx Simulated Device. Click Finish. The simulated device appears yellow 

in color.

4. Expand the M Series DAQ section. Select PCI-6220or any other PCI device of 

your choice. Click OK .

5. The NI-DAQmx Devices folder expands to show a new entry for PCI-6220: 

ñDev1.ò You have now created a simulated device.

6. Perform a self-test on the device by right-clicking it in the configuration tree and 

choosing Self-Testor clicking Self-Testalong the top of the window. This tests the 

system resources assigned to the device. The device should pass the test because it is 

already configured. 

7. Check the pinoutfor your device. Right-click the device in the configuration tree 

and select Device Pinoutsor click Device Pinoutsalong the top of the center 

window. 

8. Open the test panels. Right-click the device in the configuration tree and select Test 

Panelséor click Test Panelsé along the top of the center window. The test panels 

allow you to test the available functionality of your device, analog input/output, 

digital input/output, and counter input/output without doing any programming. 

9. On the Analog Input tab of the test panels, change Mode to ñContinuous.ò Click 

Start and observe the signal that is plotted. Click Stopwhen you are done. 



10. On the Digital I/O tab, notice that initially the port is configured to be all input. 

Observe under Select Statethe LEDs that represent the state of the input lines. 

Click the All Output button under Select Direction. Note that you now have 

switches under Select Stateto specify the output state of the different lines. Click 

Closeto close the test panels.

11. Close MAX.

End of Exercise 1 (Track B)



Exercise 1 ðSetting Up Your Device (Track C)

In this exercise, use Windows utilities to verify your sound card and prepare it for use 

with a microphone. 

1. Prepare your microphone for use. Double-click the volume control icon on the task 

bar to open up the configuration window. You also can find the sound configuration 

window from the Windows Control Panel: Start»Settings»ControlPanel»Sounds

and Audio Devices»Advanced.

2. If you do not see a microphone section, go to Options»Properties»Recordingand 

place a checkmark in the box next to Microphone. This displays the microphone 

volume control. Click OK .

3. Uncheck the Mute box if it is not already unchecked. Make sure that the volume is 

turned up. 

4. Close the volume control configuration window.

5. Open the sound recorder by selecting Start»Programs»Accessories»

Entertainment»SoundRecorder.

6. Click the record button and speak into your microphone. Notice how the sound 

signal is displayed in the sound recorder. 

7. Click Stopand close the sound recorder without saving changes when you are 

finished. 

Uncheck Mute

End of Exercise 1 (Track C)



LabVIEW

LabVIEW is a graphical programming language that uses icons instead of lines of 

text to create applications. In contrast to text-based programming languages, where 

instructions determine program execution, LabVIEW uses dataflow programming, 

where the flow of data determines execution order.

You can purchase several add-on software toolkits for developing specialized 

applications. All the toolkits integrate seamlessly in LabVIEW. Refer to the 

National Instruments Web site for more information about these toolkits. 

LabVIEW also includes several wizards to help you quickly configure your DAQ 

devices and computer-based instruments and build applications.

LabVIEW Example Finder

LabVIEW features hundreds of example VIs you can use and incorporate into VIs 

that you create. In addition to the example VIs that are shipped with LabVIEW, 

you can access hundreds of example VIs on the NI Developer Zone 

(zone.ni.com ). You can modify an example VI to fit an application, or you can 

copy and paste from one or more examples into a VI that you create.



LabVIEW programs are called virtual instruments (VIs).

Controls are inputs and indicators are outputs.

Each VI contains three main parts:

Å Front panel ïHow the user interacts with the VI

Å Block diagram ïThe code that controls the program

Å Icon/connector ïThe means of connecting a VI to other VIs

In LabVIEW, you build a user interface by using a set of tools and objects. The user 

interface is known as the front panel. You then add code using graphical representations 

of functions to control the front panel objects. The block diagram contains this code. In 

some ways, the block diagram resembles a flowchart.

You interact with the front panel when the program is running. You can control the 

program, change inputs, and see data updated in real time. Controls are used for inputs 

such as adjusting a slide control to set an alarm value, turning a switch on or off, or 

stopping a program. Indicators are used as outputs. Thermometers, lights, and other 

indicators display output values from the program. These may include data, program 

states, and other information.

Every front panel control or indicator has a corresponding terminal on the block 

diagram. When you run a VI, values from controls flow through the block diagram, 

where they are used in the functions on the diagram, and the results are passed into 

other functions or indicators through wires.



Use the Controls palette to place controls and indicators on the front panel. The 

Controls palette is available only on the front panel. To view the palette, select 

Window»ShowControls Palette. You also can display the Controls palette by right-

clicking an open area on the front panel. Tack down the Controls palette by clicking the 

pushpin on the top left corner of the palette.



Use the Functions palette to build the block diagram. The Functions palette is available 

only on the block diagram. To view the palette, select Window»ShowFunctions 

Palette. You also can display the Functions palette by right-clicking an open area on 

the block diagram. Tack down the Functions palette by clicking the pushpin on the top 

left corner of the palette.



If you enable the automatic selection tool and you move the cursor over objects on the 

front panel or block diagram, LabVIEW automatically selects the corresponding tool 

from the Tools palette. Toggle automatic selection tool by clicking the Automatic 

Selection Tool button in the Tools palette. 

Use the Operating Tool to change the values of a control or select the text within a 

control. 

Use the Positioning/Resizing Toolto select, move, or resize objects. The Positioning 

Tool changes shape when it moves over a corner of a resizable object.

Use the Labeling Tool to edit text and create free labels. The Labeling Tool changes to 

a cursor when you create free labels.

Use the Wiring Tool to wire objects together on the block diagram.

Other important tools:



Å Click the Run button to run the VI. While the VI runs, the Run button appears with a 

black arrow if the VI is a top-level VI, meaning it has no callers and therefore is not a 

subVI.

Å Click the Continuous Run button to run the VI until you abort or pause it. You also can 

click the button again to disable continuous running.

Å While the VI runs, the Abort Execution button appears. Click this button to stop the VI 

immediately.

Note: Avoid using the Abort Execution button to stop a VI. Either let the VI complete its data 

flow or design a method to stop the VI programmatically. By doing so, the VI is at a known 

state. For example, place a button on the front panel that stops the VI when you click it.

Å Click the Pause button to pause a running VI. When you click the Pause button, 

LabVIEW highlights on the block diagram the location where you paused execution. Click 

the Pausebutton again to continue running the VI.

Å Select the Text Settings pull-down menu to change the font settings for the VI, including 

size, style, and color.

Å Select the Align Objects pull-down menu to align objects along axes, including vertical, 

top edge, left, and so on.

Å Select the Distribute Objects pull-down menu to space objects evenly, including gaps, 

compression, and so on.

Å Select the Resize Objectspull-down menu to change the width and height of front panel 

objects.



Å Select the Reorder pull-down menu when you have objects that overlap each other 

and you want to define which one is in front or back of another. Select one of the 

objects with the Positioning Tool and then select from Move Forward, Move 

Backward, Move To Front, and Move To Back.

Note: The following items only appear on the block diagram toolbar.

Å Click the Execution Highlighting button to see the flow of data through the block 

diagram. Click the button again to disable execution highlighting.

Å Click the Retain Wire Values button to save the wire values at each point in the 

flow of execution so that when you place a probe on a wire, you can immediately 

obtain the most recent value of the data that passed through the wire. 

Å Click the Step Into button to single-step into a loop, subVI, and so on. Single-

stepping through a VI steps through the VI node to node. Each node blinks to denote 

when it is ready to execute. By stepping into the node, you are ready to single-step 

inside the node.

Å Click the Step Over button to step over a loop, subVI, and so on. By stepping over 

the node, you execute the node without single-stepping through the node.

Å Click the Step Out button to step out of a loop, subVI, and so on. By stepping out of 

a node, you complete single-stepping through the node and go to the next node.

Additional Tools

Retain Wire 

Values



When you create an object on the front panel, a terminal is created on the block 

diagram. These terminals give you access to the front panel objects from the block 

diagram code.

Each terminal contains useful information about the front panel object it corresponds to, 

anduses color and symbols to provide information about the data type. For example, the 

dynamic data type is a polymorphic data type represented by dark blue terminals. 

Boolean terminals are green with TF lettering.

In general, blue terminals should wire to blue terminals, green to green, and so on. This 

is not a hard-and-fast rule; you can use LabVIEW to connect a blue terminal (dynamic 

data) to an orange terminal (fractional value), for example. But in most cases, look for a 

match in colors.

Controls have a thick border and an arrow on the right side. Indicators have a thin 

border and an arrow on the left side. Logic rules apply to wiring in LabVIEW: Each 

wire must have one (but only one) source (or control), and each wire may have multiple 

destinations (or indicators).



LabVIEW uses many common data types ïBoolean, numeric, strings, clusters, and 

soon.

The color and symbol of each terminal indicate the data type of the control or indicator. 

Control terminals have a thicker border than indicator terminals. Also, arrows appear on 

front panel terminals to indicate whether the terminal is a control or an indicator. An 

arrow appears on the right if the terminal is a control and on the left if the terminal is an 

indicator. 

Definitions

Å Array: Arrays group data elements of the same type. An array consists of elements 

and dimensions. Elements are the data that make up the array. A dimension is the 

length, height, or depth of an array. An array can have one or more dimensions and 

as many as (231) ï1 elements per dimension, memory permitting. 

Å Cluster: Clusters group data elements of mixed types, much like a bundle of wires 

in a telephone cable, where each wire in the cable represents a different element of 

the cluster.

See Help»Searchthe LabVIEW Helpé for more information. The LabVIEWUser 

Manualon ni.com provides additional references for data types found in LabVIEW.



LabVIEW follows a dataflow model for running VIs. A block diagram node executes 

when all its inputs are available. When a node completes execution, it supplies data to 

its output terminals and passes the output data to the next node in the dataflow path. 

Visual Basic, C++, JAVA, and most other text-based programming languages follow a 

control flow model of program execution. In control flow, the sequential order of 

program elements determines the execution order of a program.

Consider the block diagram above. It adds two numbers and then multiplies by 2 from 

the result of the addition. In this case, the block diagram executes from left to right, not 

because the objects are placed in that order but because one of the inputs of the Multiply 

function is not valid until the Add function has finished executing and passed the data to 

the Multiply function. Remember that a node executes only when data are available at 

all of its input terminals, and it supplies data to its output terminals only when it finishes 

execution. In the second piece of code, the Simulate Signal Express VI receives input 

from the controls and passes its result to the graph. 

You may consider the add-multiply and the simulate signal code to coexist on the same 

block diagram in parallel. This means that they begin executing at the same time and run 

independently of one another. If the computer running this code had multiple 

processors, these two pieces of code could run independently of one another (each on its 

own processor) without any additional coding.



When your VI is not executable, a broken arrow is displayed in the Run button in the 

palette.

Å Finding Errors : To list errors, click on the broken arrow. To locate the bad object, 

click on the error message.

Å Execution Highlighting: Animates the diagram and traces the flow of the data, 

allowing you to view intermediate values. Click on the light bulb on the toolbar.

Å Probe: Used to view values in arrays and clusters. Click on wires with the Probe tool 

or right-click on the wire to set probes.

Å Retain Wire Values: Used with probes to view the values from the last iteration of 

the program. 

Å Breakpoint: Sets pauses at different locations on the diagram. Click on wires or 

objects with the Breakpoint tool to set breakpoints.



Exercise 2 ðAcquiring a Signal with DAQ (Track A)

Complete the following steps to create a VI that acquires data continuously from your 

DAQ device. 

1. Launch LabVIEW.

2. In the Getting Startedwindow, click the File»Newor        More é link to display 

the New dialog box. 

3. Open a data acquisition template. From the Create New list, select VI »From

Template»DAQ»DataAcquisition with NI -DAQmx.vi and click OK . 

4. Display the block diagram by clicking it or by selecting Window»ShowBlock 

Diagram. Read the instructions written there about how to complete the program. 

5. Double-click the DAQ Assistant to launch the configuration wizard. 

6. Configure an analog input operation. 

a. Choose Acquire Signals»AnalogInput»Voltage. 

b. Choose Dev1 (USB-6009)»ai0to acquire data on analog input channel 0 and 

click Finish.

c. In the next window, define the parameters of your analog input operation. 

To choose an input range that works well with your microphone, on the Settings 

tab enter 2 V for the maximum and �±2 V for the minimum. Under timing 

settingschoose ñContinuousò for the acquisition mode and enter 10000 for the 

rate. Leave all other choices set to their default values. Click OK to exit the 

wizard.

7. Place the Filter Express VI to the right of the DAQ Assistant on the block diagram. 

From the Functions palette, select Express»SignalAnalysis»Filter and place it on 

the block diagram inside the While Loop. When you bring up the Functions palette, 

press the small pushpin in the upper left-hand corner of the palette. This tacks down 

the palette so that it remains visible. This step is omitted in the following exercises, 

but you should repeat it. In the configuration window under Filtering Type , choose 

ñHighpass.ò Under Cutoff Frequency, use a value of "300 Hz." Click OK . 


