Academic Company Events Community Support Solutions Products & Services Contact NI MyNI
4 ratings:
 3.25 out of 5   

Archived: I Get the Error "Cannot Connect to Remote Server" When Using RDA With Different Versions of NI-DAQ

This document has been archived and is no longer updated by National Instruments

Note: This page is about NI-DAQ also known as Traditional NI-DAQ (Legacy). NI-DAQmx replaced Traditional NI-DAQ (Legacy) in 2003. NI strongly recommends using NI-DAQmx for new designs and migrating existing Traditional NI-DAQ (Legacy) applications to NI-DAQmx. Please review the Getting Started with NI-DAQmx guide for more information on migration.

Primary Software: Driver Software>>NI-DAQ
Primary Software Version: 6.5.0
Primary Software Fixed Version: N/A
Secondary Software: N/A

Problem: I'm getting errors when trying to network two computers for RDA. One computer has NI-DAQ 6.1.1 and the other has NI-DAQ 6.5.0. Measurement & Automation Explorer gives the error message "Cannot connect to remote server" when I try to browse to the server computer.

Solution: If you have NI-DAQ 6.5 on your client computer, you must have NI-DAQ 6.5 on your RDA server computer. You can have NI-DAQ 6.5 on the RDA server and still be able to use 6.0 and 6.1.x on your client.

This version problem was created when we added configuration calls to the RDA server. Configuration calls were added in order to integrate RDA into the configuration system to allow applications that use the configuration calls to locate and use remote devices.

Related Links: KnowledgeBase 1W4A4RUE: Do I Need to Use the Same Version of NI-DAQ When Using Remote Data Acquisition (RDA) ?


Report Date: 12/30/1998
Last Updated: 01/05/2005
Document ID: 1GTBAHW3

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
  1 2 3 4 5
Please Contact NI for all product and support inquiries.submit