Academic Company Events Community Support Solutions Products & Services Contact NI MyNI
9 ratings:
 4.11 out of 5     Rate this Document

What Hardware and Software is Supported for Use with NI Real-Time Hypervisor Systems?

Primary Software:
Primary Software Version: 2010
Primary Software Fixed Version: N/A
Secondary Software: N/A
Hardware: PXI/CompactPCI

Problem:
I am using either NI Real-Time Hypervisor for Windows or NI Real-Time Hypervisor for Linux software to run LabVIEW Real-Time and a host OS in parallel. What hardware and software are supported for use in NI Real-Time Hypervisor systems?

Solution:

Supported Hardware and Software with NI Real-Time Hypervisor for Windows Systems

Controllers
  • PXI-8108
  • PXI-8110
  • NI-3110 (a special version of the hardware is specifically designed to support the NI Real-Time Hypervisor, existing 3110 controllers can not be upgraded) (NI Real-Time Hypervisor 2.1 and earlier only)
  • PXIe-8108 (NI Real-Time Hypervisor 2.0 and later)
  • PXIe-8133 (NI Real-Time Hypervisor 2.0 and later)
  • PXIe-8135 (NI Real-Time Hypervisor 3.0 and later)
  • PXI-8119 (NI Real-Time Hypervisor 3.0 and later)
It is recommended that customers purchase complete NI Real-Time Hypervisor PXI systems with all software preinstalled from the Online PXI Advisor . To order an NI-3110 controller with the NI Real-Time Hypervisor installed, visit the web ordering page for PN 780310-03 .

PXI Chassis
  • Any non-express PXI chassis is supported (for PXI controllers)
  • PXIe-1062Q
  • PXIe-1082
  • PXIe-1065
  • PXIe-1075
  • PXIe-1078
  • PXIe-1085 (NI Real-Time Hypervisor 3.0 and later)
I/O Modules
  • In general, all plug-in I/O modules supported with LabVIEW Real-Time or Windows XP are also supported under that OS on a hypervisor system (with the following exceptions)
  • Devices that use the NI-CAN driver are not supported (NI recommends the NI-XNET driver, which is supported)
  • Devices that use the NI-DNET driver are not supported
  • PXI-6682 modules are partially supported. If used in the timing slot of a PXI Chassis, a PXI-6682 can route star lines as well as CLKIN and CLKout signals along with all other supported features except IEEE-1588 synchronization. If used in a different slot, PXI-6682 devices can use IEEE-1588 along with all other supported features except routing star lines, CLKIN, CLKOUT.
Expansion Chassis
  • NI MXI-Express RIO
  • NI Real-Time Hypervisor does not support PXI hypervisor systems connecting to another PXI I/O chassis via MXI. However, certain configurations have been known to work.
  • PXIe hypervisor systems cannot connect to another I/O chassis via MXI because the controllers for these chassis require SmBus driver support, which is not supported by hypervisor.
  • Unless listed, all other expansion connections are unsupported
Development and OS Software
  • LabVIEW 2009 must be used with NI Real-Time Hypervisor 1.0 for Windows software
  • LabVIEW 2010 must be used with NI Real-Time Hypervisor 2.0 for Windows software
  • LabVIEW 2010 or 2011 must be used with NI Real-Time Hypervisor 2.1 for Windows software
  • LabVIEW 2012 SP1 must be used with NI Real-Time Hypervisor 3.0 for Windows software
  • NI Real-Time Hypervisor 2.1 and earlier for Windows software only support Windows XP as a host OS
  • NI Real-Time Hypervisor 3.0 for Window software supports Windows XP and Windows 7 as a host OS
Supported Hardware and Software with NI Real-Time Hypervisor for Linux Systems

Controllers
  • PXI-8108
  • PXI-8110
  • PXIe-8108
  • PXIe-8133
No factory preinstallation is currently available for NI Real-Time Hypervisor for Linux systems. Customers must manually install NI Real-Time Hypervisor for Linux software along with OS and development environment software using the included instructions.

PXI Chassis
  • Any non-express PXI chassis is supported (for PXI controllers)
  • PXIe-1062Q
  • PXIe-1082
  • PXIe-1065
  • PXIe-1075
  • PXIe-1078
I/O Modules
  • In general, all plug-in I/O modules supported with LabVIEW Real-Time or Red Hat Enterprise Linux are also supported under that OS on a hypervisor system (with the following exceptions)
  • Devices that use the NI-CAN driver are not supported (NI recommends the NI-XNET driver, which is supported)
  • Devices that use the NI-DNET driver are not supported
  • PXI-6682 modules are partially supported. If used in slot 2, PXI-6682 devices can route star lines as well as CLKIN and CLKout signals along with all other supported features except IEEE-1588 synchronization. If used in a different slot, PXI-6682 devices can use IEEE-1588 along with all other supported features except routing star lines, CLKIN, CLKOUT.
Expansion Chassis
  • NI MXI-Express RIO
  • NI Real-Time Hypervisor does not support PXI hypervisor systems connecting to another PXI I/O chassis via MXI. However, certain configurations have been known to work.
  • PXIe hypervisor systems cannot connect to another I/O chassis via MXI because the controllers for these chassis require SmBus driver support, which is not supported by hypervisor.
  • Unless listed, all other expansion connections are unsupported
Development and OS Software
  • LabVIEW 2010 for Windows must be used to deploy applications to the LabVIEW Real-Time side of NI Real-Time Hypervisor for Linux systems
  • LabVIEW 2010 for Linux must be used to create applications that interface with Shared Memory on the Linux side of Real-Time Hypervisor for Linux systems
  • NI Real-Time Hypervisor for Linux software only supports Red Hat Enterprise Linux 5.5 (call NI to request support for additional versions)


Related Links:
KnowledgeBase 4YFEI84I: Frequently Asked Questions (FAQ) and Known Issues for the NI Real-Time Hypervisor
Developer Zone Tutorial: Manual Installation of an NI Real-Time Hypervisor System

Attachments:





Report Date: 05/07/2009
Last Updated: 03/11/2013
Document ID: 4X6F33DO

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
  1 2 3 4 5
Please Contact NI for all product and support inquiries.submit