Academic Company Events Community Support Solutions Products & Services Contact NI MyNI
1 ratings:
 5 out of 5   

LabVIEW Shared Library For NI Linux Real-Time Version Compatibility



Primary Software: LabVIEW Modules>>LabVIEW Real-Time Module
Primary Software Version: 2015
Primary Software Fixed Version: N/A
Secondary Software: N/A

Problem:
When I try to build or configure a Shared Library (.so) for my Real-Time Target within my LabVIEW Project I receive an error that says GNU Compiler Collection (GCC) is not installed.

What version of GCC do I need to install in order to build compatible Shared Library's for my NI Linux Real-Time target?

Solution:
In order to build a Shared Library from the LabVIEW Project you must have the appropriate version of the C/C++ Development Tools for NI Linux Real-time installed. Reference the chart below to determine the appropriate version.

LabVIEW C/C++ Development Tools for NI Linux Real-Time
2014 Eclipse Edition 2014-2016
2015 Eclipse Edition 2014-2016
2016 Eclipse Edition 2014-2016
2017 Eclipse Edition 2017


Related Links:
C/C++ Development Tools for NI Linux Real-Time, Eclipse Edition 2014-2016
C/C++ Development Tools for NI Linux Real-Time, Eclipse Edition 2017
Getting Started with C/C++ Development Tools for NI Linux Real-Time, Eclipse Edition

Attachments:





Report Date: 10/06/2014
Last Updated: 10/05/2017
Document ID: 6Q58CT1O

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
  1 2 3 4 5
Please Contact NI for all product and support inquiries.submit