Academic Company Events Community Support Solutions Products & Services Contact NI MyNI
4 ratings:
 3 out of 5   

LabVIEW and NI-488.2 Version Compatibility



Primary Software: Driver Software>>NI-488.2
Primary Software Version: 15.0
Primary Software Fixed Version: N/A
Secondary Software: LabVIEW Development Systems>>LabVIEW Base Development System

Problem:
What versions of LabVIEW are compatible with different versions of the NI-488.2 driver in a Windows OS?

Solution:
The following table shows compatibility between LabVIEW and the NI-488.2 driver software:

  LabVIEW Version
NI-488.2 Version
 
5.1
6.0
6.1
7.0
7.1
8.0
8.2
8.5
8.6
2009
2010
2011
2012
2013
2014
2015
2016
1.7                                  
2.1                                  
2.2                                  
2.3                                  
2.4                                  
2.5                                  
2.6                                  
2.7                                  
2.7.1                                  
2.7.2                                  
2.7.3                                  
2.8                                  
2.8.1                                  
3.0                                  
3.0.2                                  
3.1                                  
3.1.1                                  
3.1.2                                  
14.0                                  
15.0                                  
15.5                                  
16.0                                  


Compatible Version

Note: Driver versions 3.1.1 and later add support for Windows 8, NI-488.2 versions 14.0 add support for Windows 8.1 and currently only NI-488.2 version 15.0 supports Windows 10.

When a new version of the NI-488.2 driver is released, it is tested for the current version of LabVIEW as well as the previous two versions. Newer driver versions should work with older versions of LabVIEW, even if they have not been officially tested.

There are certain devices that only work with older driver versions. For instance, the AT-GPIB/TNT is only compatible with NI-488.2 version 1.7. It is important to verify that a driver will function with both the device and the version of LabVIEW. For information on the the most recent compatible driver with specific hardware, see the GPIB Driver Versions page.

Please see the NI-488.2 download site for more information regarding operating system compatibility, especially for non-Windows systems.

Related Links:
Drivers and Updates: NI-488.2
Documentation: GPIB Driver Versions for Microsoft Windows and DOS
Drivers and Updates: Legacy NI-488.2 Driver Request

Attachments:





Report Date: 03/04/2008
Last Updated: 02/13/2017
Document ID: 4J3A48MT

Your Feedback! poor Poor  |  Excellent excellent   Yes No
 Document Quality? 
 Answered Your Question? 
  1 2 3 4 5
Please Contact NI for all product and support inquiries.submit